2012年12月2日 星期日

fix IMarketBillingService.aidl android sdk r21 error 解法

 Android 的 ADT 升級到 21.0.0 後,
編譯 IMarketBillingService.aidl 錯誤,

IMarketBillingService.Stub.Proxy must override a superclass method IMarketBillingService.java

The method asBinder() of type IMarketBillingService.Stub.Proxy must override a superclass method IMarketBillingService.java

The method asBinder() of type IMarketBillingService.Stub must override a superclass method IMarketBillingService.java


解法:
Project specific compiler settings have to be turned off. I have the fix in my fork:
將 Project 的 compiler 改成 預設 就好了~